Fujitsu Siemens Amilo Si3655 gir ein del utfordringar

FSAmiloSi3655Dette er ein modell som skapar ein del hovudbry. Maskina spelar ikkje på lag med fullstendig diskkryptering som Truecrypt 6.x eller Compusec 5.2. For begge desse fungerer testprosedyra, men når disken er kryptert så kjem meldinga Operating System Not Found ved oppstart og der vert maskina ståande. “Fordelen” med problemet er at du kan bruke redningscden Truecrypt genererer eller lage ein USB “oppstartsnøkkel” av han på ein minnepinne med Unetbootin. Maskina vil berre starte dersom cd/"nøkkelen" blir brukt.

Med Ubuntu eller Debian aleine installert på maskina får ein same meldinga etter installasjonen. Eg valde å teste OpenSuse 11.3. Han er ikkje er basert på Debian, men utvikla av Novell. Under oppsettet av OpenSuse oppdaga eg at han brukte eit spesielt diskoppsett der eg la merke til at OpenSuse vart sett opp til å starte frå ein utvida partisjon og ikkje frå Master Boot Record. I motsetning til Ubuntu starta OpenSuse utan problem.

Sidan eg er van med Ubuntu-variantar, vart OpenSuse 11.3 litt for framand for meg. Eg måtte berre prøve å installere Ubuntu 10.04 med tilnærma lik partisjonering. Det vart gjort, men etter restart kom den velkjente meldinga Operating System Not Found opp. Eg starta maskina igjen med Ubuntu-cden og starta gparted, ein partisjonseditor. Her såg eg at oppstartspartisjonen ikkje var flagga med boot-flagget og eg sette det. Etter dette starta Ubuntu 10.04.

Ein kollega studerte på problemet. Han flytte disken til ei anna maskin og kunne konkludere med at Amilioen gav blanke i det som låg i Master Boot Record. Han hadde installert Ubuntu med standard installasjonsprosedyre og i motsetning til mi løysing, må ein faktisk fjerne boot-flagget på første partisjonen for at maskina skal starte Ubuntu.

I dag installerte eg den alternative versjonen med Xubuntu med full diskkryptering med standard oppsett. Ved restart proklamerte Amiloen som forventa Operating System Not Found. Eg starta maskina med cden Parted Magic og fjerna boot-flagget frå /boot-partisjonen. No starta Xubuntu utan problem.

For meg kan det sjå ut som om Fujitsu Siemens har modifisert BIOS slik at ein skal hindre at eit virus i Master Boot Record skal skape problem for Windows.

Advertisements

Legg att eit svar

Fill in your details below or click an icon to log in:

WordPress.com logo

Du kommenterer no med WordPress.com-kontoen din. Logg ut / Endre )

Twitter-bilde

Du kommenterer no med Twitter-kontoen din. Logg ut / Endre )

Facebook-foto

Du kommenterer no med Facebook-kontoen din. Logg ut / Endre )

Google+ photo

Du kommenterer no med Google+-kontoen din. Logg ut / Endre )

Koplar til %s